Информатика, вопрос задал Glargo21 , 9 лет назад

Написать программу, ожидающую от пользователя число (номер года) и выводящую информацию о том, високосный этот год или нет

Ответы на вопрос

Ответил A1dar
0
В григорианском календаре високосным является:
- год, номер которого делится нацело на 400
- год, номер которого делится на 4, но не делится на 100
Программа на паскале:
var n: integer;
begin
  read(n);
  if (n mod 400 = 0) or (n mod 4 = 0) and (n mod 100 > 0)
  then writeln(n, ' год високосный')
  else writeln(n, ' год невисокосный');
end.
Новые вопросы