Информатика, вопрос задал innessabest , 8 лет назад

Написать программу, определяющую сумму/количество элементов массива, значение которых больше 1 и меньше 5.

На языке С++

Ответы на вопрос

Ответил clinteastwood2
0
#include <iostream>
#include <array>
#include <numeric>
using namespace std;

const size_t N = 10;

int main()
{
    size_t sum = 0;
    array<int, N> a = { 1, 5, 9, 6, 3, 0, 1, 4, -2, 4 };
    cout << "Count: ";
    cout << accumulate(a.cbegin(), a.cend(), 0, [&sum](size_t count, const int
num) {
                                                    if (num > 1 && num < 5) {
                                                        ++count;
                                                        sum += num;
                                                    }
                                                    return count;
                                                });
    cout << " Sum: " << sum << endl;
}
Новые вопросы