Информатика, вопрос задал milenchhik , 1 год назад

Написать программу, определяющую по введенным сторонам является ли 4-х угольник квадратом илк прямоугольником, учитывая, что углы = 90 °
помогите пожалуйста

Ответы на вопрос

Ответил Dilorf
0

Ответ:

Не знаю, на каком тебе языке надо. Накидал сразу на двух

Pascal:

var

 a, b, c, d: real;

begin

 writeln('Введите длину первой стороны: ');

 readln(a);

 writeln('Введите длину второй стороны: ');

 readln(b);

 writeln('Введите длину третьей стороны: ');

 readln(c);

 writeln('Введите длину четвертой стороны: ');

 readln(d);

 if (a = b) and (b = c) and (c = d) then

   writeln('Это квадрат')

 else if ((a = c) and (b = d)) or ((a = b) and (c = d)) or ((a = d) and (b = c)) then

   writeln('Это прямоугольник')

 else

   writeln('Это не квадрат и не прямоугольник');

 readln;

end.

Python:

a = float(input("Введите длину первой стороны: "))

b = float(input("Введите длину второй стороны: "))

c = float(input("Введите длину третьей стороны: "))

d = float(input("Введите длину четвертой стороны: "))

if a == b == c == d:

   print("Это квадрат")

elif a == c and b == d or a == b and c == d or a == d and b == c:

   print("Это прямоугольник")

else:

   print("Это не квадрат и не прямоугольник")

Новые вопросы