Написать программу, определяющую количество дней в месяце Алгоритм решения задачи: Переменная d имеет тип данных запись и содержит два поля: year – для хранения года и month – для месяца. Пользователь вводит год и месяц. 8 Оператор выбора case по номеру месяца определяет количество дней в нем. Ситуация осложняется тем, что в феврале может быть как 28 дней, так и 29 (в високосный год). Год является високосным, если делится без остатка на 4 и при этом не является последним годом столетия, за исключением того столетия, которое без остатка делится на 400.
Ответы на вопрос
Ответил Аноним
2
Type
data = record
year:integer;
month:byte;
End;
Var
d:data;
Begin
Write('Год: ');ReadLn(d.year);
Write('Месяц: ');ReadLn(d.month);
Write('Количество дней в этом месяце: ');
Case d.month of
1,3,5,7,8,10,12:WriteLn(31);
4,6,9,11:WriteLn(30);
2:if (d.year mod 4 = 0)and((d.year mod 100 <> 0)or(d.year mod 400 = 0)) then WriteLn(29)
else WriteLn(28)
End;
End.
data = record
year:integer;
month:byte;
End;
Var
d:data;
Begin
Write('Год: ');ReadLn(d.year);
Write('Месяц: ');ReadLn(d.month);
Write('Количество дней в этом месяце: ');
Case d.month of
1,3,5,7,8,10,12:WriteLn(31);
4,6,9,11:WriteLn(30);
2:if (d.year mod 4 = 0)and((d.year mod 100 <> 0)or(d.year mod 400 = 0)) then WriteLn(29)
else WriteLn(28)
End;
End.
Новые вопросы
История,
1 год назад
Алгебра,
2 года назад
Английский язык,
2 года назад
История,
7 лет назад
Физика,
7 лет назад