Информатика, вопрос задал iliasklyarov , 7 лет назад

написать программу, определяющую кол-во отрицательных и нечетных элементов одномерного массива значения которого заданы с клавиатуры
В паскале

Ответы на вопрос

Ответил huston81
1

Ответ:

pascal

Объяснение:

var a : array of integer;

   i, ko, kn, n: integer;

begin

 Write('Введите размер массива: '); ReadLn(n);

 SetLength(a, n);

 for  i := 0 to n - 1 do

 begin

   Write('Введите a[',i,'] = '); ReadLn(a[i]);

   if a[i] < 0 then ko := ko + 1;

   if a[i] mod 2 = 1 then kn := kn + 1;

 end;

 WriteLn('Кол-во отрицательных элементов: ', ko);  

 WriteLn('Кол-во нечетных элементов: ', kn);  

end.

Новые вопросы