Информатика, вопрос задал zzzPhenomenalOnezzz , 8 лет назад

Написать программу определяющую, что точка принадлежит треугольнику на языке С координаты вершин треугольника(-1;0) (0;1) (1;0).

Ответы на вопрос

Ответил petyaGavrikov
0
#include <stdio.h>

int main() 
{
  float x,y;
  scanf("%f",&x);
  scanf("%f",&y);
  if (y>=0 && y<=-x+1 && y<=x+1) printf("YES");
  else printf("NO");
  return 0;
}

Пример:
-0.2 0.2
YES
Новые вопросы