написать программу обработки одномерного массива :1 ввести массив с клавиатуры с запросом(а[1]=,a[2]=, и т.д)
найти сумму чётных элементов массива.
Ответы на вопрос
Ответил Andrey05
0
Ответил Mango123
0
const n=(задайте нужное количество элементов массива);
var a: array [1..n] of integer;
i: byte; sum: integer;
begin
sum :=0;
for i:=1 to n do
begin
write('a[',i,']= '); readln(a[i]);
if a[i] mod 2=0 then sum:=sum+a[i];
end;
writeln;
write(sum);
readln;
end.
var a: array [1..n] of integer;
i: byte; sum: integer;
begin
sum :=0;
for i:=1 to n do
begin
write('a[',i,']= '); readln(a[i]);
if a[i] mod 2=0 then sum:=sum+a[i];
end;
writeln;
write(sum);
readln;
end.
Приложения:
Новые вопросы