Информатика, вопрос задал kjuliyaa , 2 года назад

Написать программу: Найти квадрат наибольшего из двух чисел: а и b и корень квадратный наименьшего числа. Вывести полученные значения. Если a и b равны, вывести сообщение об этом.

Ответы на вопрос

Ответил SantiVlad
0

Ответ:

static void Main(string[] args)

       {

           int a, b;

           Console.Write("Введите число a: ");

           a = Convert.ToInt32(Console.ReadLine());

           Console.Write("Введите число b: ");

           b = Convert.ToInt32(Console.ReadLine());

           int min = a;

           int max = a;

           if (b > max)

           {

               max = b;

           }

           if (b < min)

           {

               min = b;

           }

           if (a == b)

           {

               Console.WriteLine();

               Console.Write("Числа a и b равны.");

           }

           Console.WriteLine();

           Console.Write("Квадрат наибольшего числа = " + Math.Pow(max, 2));

           Console.WriteLine();

           Console.Write("Корень квадратный наименьшего числа = " + Math.Sqrt(min));

           Console.ReadKey();

       }

Объяснение:

Код на языке C#.

Ответил BobbyFresnel
0

===== PascalABC.NET =====

begin

 var (a, b) := ReadReal2('Введите два неотрицательных числа:');

 if a = b then

   Println('Введенные числа равны')

 else  

   Println('Квадрат наибольшего:', Sqr(Max(a,b)),

     '  корень квадратный наименьшего:', Sqrt(Min(a,b)));

end.

Приложения:
Новые вопросы