Информатика, вопрос задал konopleva75 , 9 лет назад

Написать программу нахождения в вещественном массиве из 10 элементов, количества отрицательных и превышающих -30.

Ответы на вопрос

Ответил A1dar
0
//Pascal

var
  a: array[1..10] of real;
  i, count: integer;
   
begin
  count := 0;
 
  write('Исходный массив: ');
 
  for i := 1 to 10 do
  begin
 
    {Генерация}
    a[i] := random(200) + Random() - 100;
   
    {Вывод}
    write(a[i] : 0 : 5, ' ');
   
    {Проверка}
    if (a[i] > -30) and (a[i] < 0) then inc(count);
   
  end;
 
  writeln;
  writeln('Количество отрицательных элементов, превышающих -30: ', count);
end.

Новые вопросы