Написать программу нахождения суммы и среднего арифметического значения элементов целочисленного массива размерностью n. С помощью одномерного массива.
n равен количеству 5
*размерность - количество элементов массива
Ответы на вопрос
Ответил nastikots
1
Ответ:
program z1;
const n=5;
var i,s: integer;
a:array[1..n] of integer;
begin
s := 0;
write('Массив : ');
for i:=1 to n do
begin
a[i]:=random(10);
write(a[i]:3);
s:=s+a[i]
end;
writeln;
writeln('Сумма значений элементов целочисленного массива ',s);
writeln('Среднее арифметическое значений элементов целочисленного массива ',s/n)
end.
Объяснение:
n - размерность массива
s - сумма значений элементов
В цикле с параметром:
1) задаём значение элемента массива
2) выводим элемент на экран
3) считаем сумму
Выводим на экран сумму
Выводим на экран среднее арифметическое (делим сумму на количество элементов массива)
agata74548:
помогите пожалуйста
Новые вопросы