Информатика, вопрос задал vampire0110 , 10 лет назад

Написать программу нахождения сопротивления цепи из n резисторов (r1,r2, ..rn) соединённых последовательно (PascalABC)

Ответы на вопрос

Ответил Sky09
0
При последовательном соединении сопротивление цепи будет равно сумме сопротивлений.
uses crt;
var r:array [1..10000] of integer;
    n,x,RSum:integer;
begin
     RSum:=0;
     write('N='); readln(N);
     for x:=1 to N do
     begin
          write('R',x,'=');
          readln(r[x]);
          RSum:=RSum+r[x];
     end;
     writeln('R=',RSum);
end.     
Ответил sellsaccount
0
var a, n, i, s : integer;
begin
read (n);
for i:=1 to n do 
 begin
 read (a);
 s:=s+a;
 end;
write (s);
end.

В последовательном соединении R_c=R_1+R_2+R_3+...+R_n

P.S. Надеюсь на благодарность и лучший ответ.
Новые вопросы