Информатика, вопрос задал nastakudra44574 , 2 года назад

Написать программу нахождения разности произведения и суммы натурального ряда чисел от одного до n. На языке Pascal.


nastakudra44574: Найти P-S, где Р это произведение, а S сумма!!!
nastakudra44574: не надо отдельно искать разность
nastakudra44574: произведение минус сумма
nastakudra44574: вот что мне надо
KennyLans: Ну я рад, необходимо изначально так писать. Я уже не буду исправлять, можете отмечать как нарушение.
nastakudra44574: даже если подумать, если бы надо было искать разность, я бы поставила запятую, после слова "разности"
KennyLans: Знаете сколько здесь неграмотных людей?)
KennyLans: Поэтому уже по привычке
nastakudra44574: Если я сделаю новый вопрос, ответите на него?

Ответы на вопрос

Ответил KennyLans
0
  • Program Brainly;
  • Var I,N,S,R,P:integer;
  • Begin
  • Repeat
  • Write('Введите число для натурального ряда:');
  • Readln(N);
  • Until N > 0;
  • For I:= 1 to N do
  • S:= S + I;
  • Writeln('Сумма чисел:',S);
  • P:= 1;
  • For I:= 1 to N do
  • P:= P * I;
  • Writeln('Произведение чисел:',P);
  • R:= P - S;
  • Writeln('Разность чисел:',R);
  • end.
Приложения:

nastakudra44574: Нужно произведение - сумма
Артур998: https://znanija.com/task/40471862 помогите с информатикой пожалуйста 100б
Новые вопросы