Информатика, вопрос задал alsu9436 , 7 лет назад

Написать программу нахождения площади высоты, радиусов вписанной и описанной окружности равностороннего треугольника со стороной а.​

Ответы на вопрос

Ответил IlYaToL
0

Ответ:

# Python 3.7.2

from math import sqrt

a = int(input())

h = sqrt(3) / 2 * a

r = a / (2 * sqrt(3))

R = a / sqrt(3)

print('Высота:', h)

print('Радиус вписанной окружности:', r)

print('Радиус описанной окружности:', R)

Ответил alsu9436
0
можете помочь?
Ответил HappyCoder
0

PascalABC.Net

  • procedure Rad(a: real; n: integer);
  • var
  •  R, R2: real;
  • begin
  •  R := a / (2 * sin(pi / n));
  •  R2 := R * cos(pi / n);
  •  Println('Радиус (Описаный): ', R);
  •  Println('Радиус (Вписаный): ', R2);
  • end;
  • begin
  •  var a := ReadReal('Введите A: ');
  •  var n := ReadInteger('Введите N: ');
  •  Rad(a, n);
  • end.

Varian 2

  • program HappyCoder;
  • var
  •  R, R2, A: real;
  •  n: integer;
  • begin
  •  Writeln('Введите A: ');
  •  Read(A);
  •  Writeln('Введите N: ');
  •  Read(n);
  •  R := a / (2 * sin(pi / n));
  •  R2 := R * cos(pi / n);
  •  Writeln('Радиус (Описаный): ', R:0:3);
  •  Writeln('Радиус (Вписаный): ', R2:0:3);
  • end.
Новые вопросы