Написать программу нахождения наибольшего общего делителя (НОД) двух натуральных чисел.а)использовать оператор repeatб) использовать оператор while
Ответы на вопрос
Ответил Easystreet
0
var a,b: integer;
function NOD(x,y: integer): integer;
begin
if x<>0 then NOD:=NOD(y mod x,x) else NOD:=y;
end;
begin
readln(a,b);
writeln( 'НОД = ', NOD(a,b) );
end.
function NOD(x,y: integer): integer;
begin
if x<>0 then NOD:=NOD(y mod x,x) else NOD:=y;
end;
begin
readln(a,b);
writeln( 'НОД = ', NOD(a,b) );
end.
Ответил Easystreet
0
Такой алгоритм знаю, через while сейчас не вспомню, извините
Новые вопросы