Информатика, вопрос задал ЮLь4а , 9 лет назад

написать программу нахождения минимального элемента и его номера в целочисленном массиве. Элементы массива заданы случайным образом из промежутка от -10 до 45
на С++,пожалуйста.

Ответы на вопрос

Ответил ManulTheLiar
0
#include <iostream>
#include <Time.h>
using namespace std;

int main()
{
    int n, i, k;

    cout << "Kolichestvo chisel = ";
    cin >> n;

    srand(time(0));
    int *a = new int[n];

    for (int i = 0; i < n; i++)
    {
        a[i] = rand() % 56 - 10;
        cout << a[i] << " ";
    }
    int min = a[0];

    for (i = 0; i<n; i++)
    if (min>a[i]) {
        min = a[i];
        k = i;
    }

    cout << endl << endl;
    cout << "Min = " << min << endl << "i = " << k << endl;

    system("pause");
    return 0;
}
Новые вопросы