Написать программу, нахождения максимального значения функции у=7/х+25х^3 на отрезке [1;20]
9 класс
Ответы на вопрос
Ответил nastikots
1
Ответ:
program z1;
var i,mx:integer;
begin
mx:=1;
for i:= 1 to 20 do
begin
if 7/mx+25*sqr(mx)*mx < 7/i+25*sqr(i)*i then mx:=i;
writeln('x = ',i:2,' y = ',7/i+25*sqr(i)*i:0:3)
end;
writeln('максимальное значение функции ',7/mx+25*sqr(mx)*mx:0:3)
end.
Объяснение:
Предполагаем что максимальное значение функция принимает в начальной точке отрезка (переменная mx)
Цикл:
берём значения из отрезка с шагом +1 и проверяем больше значение функции в этой точке, чем значение функции, вычисленной с переменной mx, если больше, то меняем значение переменной mx на текущее
выводим значение функции на экран
Выводим максимальное значение функции
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
История,
2 года назад
Математика,
2 года назад
Литература,
8 лет назад