Написать программу нахождения количества рулонов обоев, необходимых для ремонта комнаты
ВикаБач:
Это очень сложная программа получится... Обои имеют повторяющийся рисунок, это нужно учитывать, НО на фабрике их режут, не обращая внимания на рисунок, поэтому каждый рулон индивидуален, и узнать, какой он, можно, только купив его! Так что написать программу нереально! Ну, если только для однотонных обоев, но об этом в условии ничего не сказано.
Ответы на вопрос
Ответил giftig89
0
1 uses crt;
2 var d,s,p,v,rez: real;
3
4 begin
5 write ('Укажите длину рулона обоев ');
6 readln (d);
7 write ('Укажите ширину рулона обоев ');
8 readln (s);
9 write ('Укажите высоту комнаты ');
10 readln (v);
11 write ('Укажите периметр комнаты ');
12 readln (p);
13 rez:=(round((p/s)*v)/d);
14 writeln ('Для оклейки понадобятся ',rez,' рулонов обоев');
15 end.
Новые вопросы
Русский язык,
2 года назад
Алгебра,
2 года назад