Написать программу нахождения количества чётных чисел в массиве случайных чисел
Ответы на вопрос
Ответил Gleb1Kosyrev
0
//Pascal ABC.NET v3.0 сборка 1111
Const
n=5;
Var
ar:array[1..n] of integer;
i,k:integer;
begin;
randomize;
k:=0;
writeln('Array:');
for i:=1 to n do
begin;
ar[i]:=random(10);
write(ar[i]:4);
if not odd(ar[i]) then inc(k);
end;
writeln;
write('Res=',k);
end.
Const
n=5;
Var
ar:array[1..n] of integer;
i,k:integer;
begin;
randomize;
k:=0;
writeln('Array:');
for i:=1 to n do
begin;
ar[i]:=random(10);
write(ar[i]:4);
if not odd(ar[i]) then inc(k);
end;
writeln;
write('Res=',k);
end.
Ответил renatsibaev
0
а как без константы и odd, и inc?
Ответил A1dar
0
not odd(a[i]) замени на a[i] mod 2 = 0
Ответил A1dar
0
а inc(k) на k := k + 1
Новые вопросы
Алгебра,
2 года назад
Алгебра,
2 года назад
Математика,
9 лет назад
Математика,
9 лет назад
Математика,
9 лет назад