Информатика, вопрос задал feniks198878 , 7 лет назад

Написать программу находящую максимальную цифру пятизначного числа.​

Ответы на вопрос

Ответил denismikhailov
0

Ответ:

Pascal

var a, b, max:Integer;

begin

max:=0;

readln(a);

for b := 1 to 5 do begin

if max < (a mod 10) then

max:=a mod 10;

a:=a div 10;

end;

writeln(max);

end.

Ответил feniks198878
0
прости а после разве begin не ставится точка с запятой(я просто не шарю в информатике и сам по себе тупой)
Ответил denismikhailov
0
Только один недочёт здесь есть в плане, что программа обрабатывает не только 5-значные числа, а все.
Новые вопросы