Информатика, вопрос задал Кирилл2001474 , 2 года назад

Написать программу (на языке Си), которая находит все двузначные числа, для
которых сумма цифр входящих в число плюс квадрат суммы этих же цифр
равна самому числу.


Кирилл2001474: Там чередование чисел идет
restIess: мне бы знать, подходят эти числа или нет...
Кирилл2001474: Есть наброски программы?
restIess: Та я на питоне написал, на СИ перекинуть не проблема, надо ток утвердить, что я правильно посчитал)
Кирилл2001474: По моему там 10,20,30,40,50,60,70,80,90
restIess: квадрат суммы это a^2 + 2ab + b^2, 1 + 0 + 0 - квадрат суммы цифр и плюс сумма цифр, 1 + 1 = 2, а нам нужно 10 => 10 не подходит
Кирилл2001474: Есть такое
Кирилл2001474: Я пробовал писать программу, но вот с условием как раз не получилось
restIess: а ты уверен, что такие числа вообще есть?
restIess: 3 числа таких, ща на СИ перепишу

Ответы на вопрос

Ответил restIess
1

#include <stdio.h>

#include <math.h>

int main(){

   for (int i = 10; i< 100;i++)    

       if ((pow(i%10+i/10,2) + i%10 + i/10) == i)

           printf("%d\n",i);

   return 0;

}


Кирилл2001474: Можешь посмотреть еще вот https://znanija.com/task/42364694
Новые вопросы