Написать программу на языке Си.
Дано целое число N и последовательность, состоящая из N целых чисел. Вывести
сумму чисел из данной последовательности, которые больше своего левого соседа.
Ответы на вопрос
Ответил yobaresh
0
#include <stdio.h>
int main() {
int n;
scanf("%d", &n);
int a, b, tmp, ans = 0;
scanf("%d", &tmp);
for (int i = 1; i < n; i++)
{
int a;
scanf("%d", &a);
if (a > tmp)ans += a;
tmp = a;
}
printf("%d", ans);
getchar();
getchar();
return 0;
}
Новые вопросы
Русский язык,
2 года назад
Английский язык,
2 года назад
История,
2 года назад
Русский язык,
2 года назад
Математика,
8 лет назад