Информатика, вопрос задал TAO9909 , 1 год назад

Написать программу на языке С++(со всеми ОБЪЯСНЕНИЯМИ пожалуйста)
Написать функцию, которая возвращает 1, если одномерный массив, полученный функцией в качестве аргумента, является упорядоченным по убыванию.​

Ответы на вопрос

Ответил BobbyFresnel
1

#include <iostream>

using namespace std;

int F(int a[], int n)   // сама функция

{

   int m = a[0];           // первый элемент запомнили

   for(int i=1; i<n; i++)  // цикл по остальным элементам

       if(a[i]<m)              // если очередной меньше запомненного,

           m=a[i];             // то запоминаем этот элемент, хорошо

       else                    // иначе

           return 0;           // возвращаем 0, плохо

   return 1;               // если все было хорошо, вернем 1

}

int main()  // тестовая программа

{

   int n;

   cin >> n;   // ввод размера массива

   int b[n];   // описали массив нужного размера

   for(int i=0; i<n; i++) cin >> b[i]; // цикл ввода элементов

   cout << "Result: " << F(b, n); // тестируем функцию

   return 0;

}

Новые вопросы