Написать программу на языке С(Си) Пусть процедура Socr (a,b,p,q) от целых параметров (b≠0) приводит дробь a/b к несократимому виду p/q. Описать данную процедуру и использовать её для приведения дроби 1+1/2+1/3+...+1/20 к несократимому виду c/d.
Ответы на вопрос
Ответил Аноним
0
#include<stdio.h>
#include<conio.h>
int Socr(long long int a, long long int b, long long int *p, long long int *q)
{
long long int d;
int c = 0;
if (a)
{
if((float)a/b<0)
{
if(a<0) a=-a;
if(b<0) b=-b;
c = 1;
}
for(d = (a>b?b:a); (a%d!=0||b%d!=0); d--);
if (c) *p = -a / d;
else *p = a / d;
*q = b / d;
}
else
{
*p = 0;
*q = 1;
}
return 0;
}
int main(int argc, char *argv[])
{
long long int a = 1, b, p = 1, q = 1;
for(b = 2; b < 21; b++)
{
printf("%lli/%lli + 1/%d = ",p,q,b);
Socr(p*b+q,q*b,&p,&q);
printf("%lli/%lli\n",p,q);
}
getch();
}
#include<conio.h>
int Socr(long long int a, long long int b, long long int *p, long long int *q)
{
long long int d;
int c = 0;
if (a)
{
if((float)a/b<0)
{
if(a<0) a=-a;
if(b<0) b=-b;
c = 1;
}
for(d = (a>b?b:a); (a%d!=0||b%d!=0); d--);
if (c) *p = -a / d;
else *p = a / d;
*q = b / d;
}
else
{
*p = 0;
*q = 1;
}
return 0;
}
int main(int argc, char *argv[])
{
long long int a = 1, b, p = 1, q = 1;
for(b = 2; b < 21; b++)
{
printf("%lli/%lli + 1/%d = ",p,q,b);
Socr(p*b+q,q*b,&p,&q);
printf("%lli/%lli\n",p,q);
}
getch();
}
Новые вопросы
Литература,
1 год назад
Литература,
1 год назад
Русский язык,
2 года назад
Русский язык,
2 года назад
Физика,
7 лет назад