Информатика, вопрос задал anyaantonova1 , 10 лет назад

написать программу на языке С#:. Последовательность
целых ненулевых чисел вводится с клавиатуры. Окончанием последовательность
является 0. Определите

произведение чисел, которые делятся на 5

Ответы на вопрос

Ответил archery
0
using System;


namespace ConsoleApp {
    internal class Program {
        private static void Main() {
            var product = 1;
            int n;
            do {
                Console.WriteLine("Введите число");
                n = Convert.ToInt32(Console.ReadLine());
                if (n != 0 && n % 5 == 0) {
                    product *= n;
                }
            } while (n != 0);
           
            Console.WriteLine("Product = " + product);

            Console.ReadKey();
        }
    }
}

Новые вопросы