Написать программу на языке С (не С++!!!) для сортировки модификацией пузырька "чёт-нечёт".
Ответы на вопрос
#include <stdio.h>
#include <stdlib.h>
#include <time.h>
#define n 10
int main()
{
srand(time(NULL));
int arr[n];
int tmp;
/*Заполняем массив случайными числами и выводим на экран*/
for (int i = 0; i < n;i++)
{
arr[i] = rand() % 10;
printf("%i ", arr[i]);
}
/*Сортировка*/
for (int i = 0; i < n; i++) {
if (i % 2 == 0)
for (int j = 2; j < n; j += 2) {
if (arr[j] < arr[j - 1]) {
tmp = arr[j];
arr[j] = arr[j - 1];
arr[j - 1] = tmp;
}
}
else
for (int j = 1; j < n; j += 2) {
if (arr[j] < arr[j - 1]) {
tmp = arr[j];
arr[j] = arr[j - 1];
arr[j - 1] = tmp;
}
}
}
/*Вывод отсортированного массива на экран*/
printf("\n");
for (int i = 0; i < 10; i++)
{
printf("%i ", arr[i]);
}
return 0;
}