Информатика, вопрос задал anyaantonova1 , 10 лет назад

написать программу на языке с#:Дана точка на плоскости с координатами (х, у). Составить программу,
которая выдает одно из сообщений «Да», «Нет», «На границе» в зависимости от
того, лежит ли точка внутри заштрихованной области, вне заштрихованной области
или на ее границе. 

Приложения:

Ответы на вопрос

Ответил archery
0
using System;


namespace ConsoleApp {
    internal class Program {
        private static void Main() {
            Console.WriteLine("Введите x");
            var x = Convert.ToInt32(Console.ReadLine());
            Console.WriteLine("Введите y");
            var y = Convert.ToInt32(Console.ReadLine());

            if (Math.Abs(x) <= y && x * x + y * y <= 15 * 15) {
                if (Math.Abs(x) == y || x * x + y * y == 15 * 15) {
                    Console.WriteLine("На границе");
                }
                else {
                    Console.WriteLine("Да");
                }
            }
            else {
                Console.WriteLine("Нет");
            }

            Console.ReadKey();
        }
    }
}

Новые вопросы