Информатика, вопрос задал chirkovmikhail08 , 1 год назад

Написать программу на языке PYTHON (ПИТОН)
Вводятся 2 натуральных числа , программа должна вывести сумму всех чисел, лежащих между заданными числами. Если заданы числа, между которыми нет других чисел, вывести сообщение:" чисел нет!"

пример:

Ввод

4

7

Вывод 11 (5+6)


Ввод

4

5

Вывод Чисел нет!

Ответы на вопрос

Ответил Anigoo1
1

Ответ:

Код программы на Python:

=-| PYTHON |-=

a = int(input("Введите первое число: "))

b = int(input("Введите второе число: "))

s = 0

if a < b:

   for i in range(a+1, b):

       s += i

   if s == 0:

       print("Чисел нет!")

   else:

       print("Сумма чисел между заданными числами: ", s)

else:

   for i in range(b+1, a):

       s += i

   if s == 0:

       print("Чисел нет!")

   else:

       print("Сумма чисел между заданными числами: ", s)

 =-| END |-=

Объяснение:

Как работает программа:

1. Считываем два числа, введенных пользователем, с помощью функции input.

2. Создаем переменную s, которую будем использовать для суммирования чисел между a и b.

3. Определяем, какое число больше - a или b, чтобы правильно задать границы для итерации.

4. Используя цикл for, находим сумму всех чисел между a и b (исключая a и b).

5. Если сумма чисел между a и b равна 0, выводим соответствующее сообщение.

6. Иначе, выводим сумму чисел методом print.

Новые вопросы