Информатика, вопрос задал chirkovmikhail08 , 1 год назад

Написать программу на языке PYTHON (ПИТОН)
1.Написать программу, которая для заданного числа (вводится с консоли) выводит разность всех натуральных чисел до заданного числа.
Пример:
Ввод 4
Вывод -8
(1-2-3-4)​

Ответы на вопрос

Ответил RenSolo
1

n = int(input("Введите число: ")) //получаем число "барьер" с клавиатуры

s = 1 //вводим единицу, как первое натуральное число

for i in range(2, n+1):

   s -= i

print(s)

Новые вопросы