Написать программу на языке программирования высокого уровня С++ вычисляющую количество введенных чисел и максимальный элемент из входного потока. Данные ввести с клавиатуры и записать во внешний файл на диске. Количество введенных чисел не ограничено. Признак окончания ввода чисел во входном потоке - число 421.
После записи введенных данных в конец файла дописать количество введенных чисел и максимальное введенное число. Например, Количество введенных чисел - 12, максимальное среди введенных - 345, причем признак окончания ввода - последнее число 421 не учитывать.
Ответы на вопрос
Ответил Milton812
0
#include <iostream>
#include <fstream>
int main()
{
setlocale(LC_ALL, "RUSSIAN");
std::ofstream file("file.txt");
int cr=0;
int max = 0;
int count = 0;
do
{
std::cout << "Введите число >> ";
std::cin >> cr;
if (cr > max)
max = cr;
if(cr!=421)
file << cr << std::endl;
count++;
} while (cr != 421);
file << "Количество введенных чисел: " << count << std::endl;
file << "Максимальное введенное число: " << max << std::endl;
}
#include <fstream>
int main()
{
setlocale(LC_ALL, "RUSSIAN");
std::ofstream file("file.txt");
int cr=0;
int max = 0;
int count = 0;
do
{
std::cout << "Введите число >> ";
std::cin >> cr;
if (cr > max)
max = cr;
if(cr!=421)
file << cr << std::endl;
count++;
} while (cr != 421);
file << "Количество введенных чисел: " << count << std::endl;
file << "Максимальное введенное число: " << max << std::endl;
}
Новые вопросы
Русский язык,
1 год назад
Русский язык,
1 год назад
Математика,
2 года назад
Геометрия,
2 года назад
Математика,
7 лет назад
Математика,
7 лет назад