Написать программу на языке программирования C#
Задача
Время прибытия поезда на станцию h1 ч. и m1 м. Время отправления h2 ч. и m2 м. Человек пришёл на станцию в h3 ч. и m3 м. Попал ли он на этот поезд (или пришёл раньше или опоздал)?
Ответы на вопрос
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace ConsoleApp1
{
class Program
{
static void Main(string[] args)
{
int h1, h2, h3, m1, m2, m3;
Console.WriteLine("Введите время прибытия поезда (часы):");
h1 = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите время прибытия поезда (минуты):");
m1 = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите время отправления поезда (часы):");
h2 = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите время отправления поезда (минуты):");
m2 = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Во сколько человек пришёл на станцию (часы):");
h3 = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Во сколько человек пришёл на станцию (минуты):");
m3 = Convert.ToInt32(Console.ReadLine());
if (h1 < 0 || h1 > 23 || h2 < 0 || h2 > 23 || h3 < 0 ||
h3 > 23 || m1 < 0 || m1 > 59 || m2 < 0 || m2 > 59 || m3 < 0 || m3 > 59)
{
Console.WriteLine("Время указано неверно.");
}
else
{
if (h2 > h3)
{
Console.WriteLine("Пришёл раньше.");
}
else if (h2 < h3)
{
Console.WriteLine("Опоздал.");
}
else if (h2 == h3 && m2 > m3 || h2 == h3 && m2 == m3)
{
Console.WriteLine("Попал на поезд.");
}
else
{
Console.WriteLine("Опоздал.");
}
}
Console.ReadKey();
}
}
}