Информатика, вопрос задал aviktoria2006 , 6 лет назад

написать программу на языке Паскаль : Вводим число 58, найти произведение цифр этого числа, а затем найти остаток от деления 58 и полученного числа.


valgrisa: число всегда двузначное вводится?
aviktoria2006: да

Ответы на вопрос

Ответил valgrisa
1

Ответ:

program z;

var a,p,o:integer;

begin

read(a);

p:=(a div 10) * (a mod 10);

writeln(p);

o:=58 mod p;

write(o)

end.

Объяснение:

вводим двузначное число (read(a);)

находим произведение (p:=(a div 10) * (a mod 10);) первой цифры введенного двузначного числа (a div 10) и второй (a mod 10)

выводим полученное произведение на экран (writeln(p);)

находим остаток (o:=58 mod p;) от введённого числа (a) на полученное произведение цифр числа (p)

выводим полученный остаток на экран (write(o))

div - целочисленное деление

mod - остаток от целочисленного деления

58 / 10 = 5,8

58 div 10 = 5

58 mod 10 = 58 - 10 * 5 = 58 - 50 = 8

Новые вопросы