Информатика, вопрос задал kuzinakat , 10 лет назад

написать программу на языке паскаль (разветвляющийся алгоритм):
1) F=x2-3 (икс в квадрате минус три), x2=x*x (x в квадрате равен x умножить на x)
2) S=1/2ab (одна вторая а б)
3) С=a2-b2 (а в квадрате минус б в квадрате)

Ответы на вопрос

Ответил PopCop312
0
var x,f,s,c,a,b:real;
begin
write('X = ');
readln(x);
write('A = ');
readln(a);
write('B = ');
readln(b);
f:=x*x-3;
s:=a*b/2;
c:=a*a-b*b;
writeln('F=',f:3:2,' S=',s:3:2,' C=',c:3:2);
end.
Ответил PopCop312
0
если что то непонятно, обращаейтсь
Ответил isakaev
0
1) Не разветвление)
program xizt;
uses crt;
var x,f:real;
begin
 writeln ('введите х');
readln (x);
f:=sqr(x)-3;
writeln (f);
end.
2) program xizt;
uses crt;
var a,b,s:real;
begin
 writeln ('введите a,b через пробел');
readln (a,b);
s:=1/2*a*b
writeln (s);
end.
3) program xizt;
uses crt;
var a,b,c:real;
begin
 writeln ('введите a,b через');
readln (a,b);
c:=sqr(a)-sqr(b);
writeln (c);
end.
Новые вопросы