Информатика, вопрос задал ЛЕНА1ЛЕНА , 9 лет назад

написать программу на языке паскаль
при помощи подпрограммы функции которая вычисляет минимальное из чисел a b c d

Ответы на вопрос

Ответил cccc1808
0
PascalABC.NET

type    mass = array [1..4] of integer;

var   a : mass;   
i : integer; 

function min(c : mass) : integer;   
var   
i,minim : integer; 
begin   
minim := c[1]; 
 for i := 2 to 4 do 
  if c[i] < minim then   
  minim := c[i]; 
result := minim;   
 end;  

begin 
 for i := 1 to 4 do 
  readln (a[i]); 
writeln ('min = ',min(a)); 
end.

Как параметр я использовал массив из четырех элементов. Можно использовать просто переменные и через IF все прописать
Новые вопросы