Написать программу на языке Паскаль которая вызывает из модуля подпрограмму, которая печатает содержимое непустого текстового файла по рядкам, вставляя в начало рядка слово "рядок" и номер этого рядка(4 позиции).
viktornekrasov2000:
я извиняюсь строка
Ответы на вопрос
Ответил BobbyFresnel
0
===== PascalABC.NET =====
unit Nekrasov; // поместить в одноименный файл !!!
interface
procedure PrintText(fn: string);
implementation
procedure PrintText(fn: string);
begin
var i := 1;
foreach var s in ReadLines(fn) do
begin
Writeln(i:4, ' ', s);
i += 1
end;
end;
end.
=========================
uses nekrasov; // вызывающая программа (другой файл)
begin
var fn := ReadlnString('Укажи имя файла:');
if FileExists(fn) then
PrintText(fn)
else
Println('Файл не найден')
end.
Новые вопросы
Химия,
1 год назад
Українська мова,
1 год назад
Математика,
1 год назад
Обществознание,
1 год назад
Математика,
7 лет назад