Информатика, вопрос задал alibabo25 , 2 года назад

написать программу на языке паскаль :
Даны 3 числа a, b, с. Найти минимальное из этих чисел.
Если три числа одинаковые, необходимо что бы на экране выводилось только сообщение: Все числа равны.

Приложения:

Ответы на вопрос

Ответил nastikots
4

Ответ:

program z1;

var a,b,c,m: integer;

begin

write ('a = ');

readln(a);

write ('b = ');

readln(b);

write ('c = ');

readln(c);

if (a=b) and (b=c) then write('Все числа равны')

else

begin

m:=a;

if b<m then m:=b;

if c<m then m:=c;

write('Минимальное: ',m)

end

end.

Объяснение:

Вводим числа

Если числа равны, то выводим сообщение о равенстве

Иначе:

1) принимаем за минимальное число а

2) сравниваем его с остальными числами, при необходимости заменяем значение минимального

3) выводим минимальное число

Ответил zhoramalushevpegkpk
1

Ответ:

begin

 writeln('Введите числа: ');

 var N:Array [1..3] of real;

 readln(N[1],N[2],N[3]);

 write ((N[1]=N[2]) and (N[2]=N[3])1? 'Все числа равны':'Минимальное '+N.Min.ToString);

end.

Объяснение:

(A<>B)? R1:R2 - сокращенная форма оператора if/else, где A,B - сравниваемые значения, R1 - результат, если выражение в скобках верно, R2 - если нет.

N.Min - Находит в массиве наименьший по значению элемент, а .ToString - преобразует его в строку.

Новые вопросы