Информатика, вопрос задал MariaFrant , 9 лет назад

Написать программу на языке Паскаль
Дано: а,b,с
Найти:S
S=SQRT(p(p-a)(p-b)(p-c))
где р=(а+b+c)/2

Ответы на вопрос

Ответил Gleb1Kosyrev
0
var a,b,c,s:real;

procedure Pl(var a,b,c,s:real);
var p:real;
begin;
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln(s);
end;

begin;
readln(a);
readln(b);
readln(c);
if (a>=(b+c)) or (b>=(a+c)) or (c>=(a+b)) then
begin;
writeln('error');
exit;
end;
Pl(a,b,c,s);
end.
Новые вопросы