Информатика, вопрос задал Плювиофил , 7 лет назад

Написать программу на языке паскаль.
Циклический алгоритм с предусловием задан в виде словесного описания. Заданы начальные значения переменных:
x:=1; y:=5;
Начало цикла. Пока y>x выполнить:
y: = y – x;
k=k+1;
конец цикла;
Определить количество циклов k и значения переменной y после выхода из цикла.

Ответы на вопрос

Ответил Helper211
0

Ответ:

var x,y,k: integer;

begin

x:=1;

y:=5;

k:=0;

while (y>x) do

 begin

 y:=y-x;

 k:=k+1;

 end;

writeln('Количество циклов k: ',k);

writeln('Значение переменной y: ',y);

end.

 

Приложения:
Новые вопросы