Информатика, вопрос задал jonawormo , 7 лет назад

Написать программу на языке Паскаль АВС, заранее благодарю)

Приложения:

Ответы на вопрос

Ответил raf1O5
0

program raf105;

var fioa2:array[1..20] of string;

fioa1:string;

m1,g1,m2,g2,i,o:integer;

begin

write('Введите сегодняшнюю дату (месяц, год) через пробел: ');

readln(m1,g1);

g1:= g1*12;

m1:= m1+g1;

writeln;

for i:=1 to 20 do

begin

 write(i,'. Введите фамилию, имя, отчество и адрес сотрудника: ');

 readln(fioa1);

 write('   Дата поступления (месяц, год): ');

 readln(m2,g2);

 writeln;

 g2:= g2*12;

 m2:= m2+g2;

 if m1-m2>=36

   then begin

   o:= o+1;

   fioa2[o]:= fioa1;

   end;

end;

writeln('Сотрудники которые проработали не менее трёх лет:');

for i:=1 to o do

writeln(i,'. ',fioa2[i]);

end.

Язык программирования PascalABC

Новые вопросы