Информатика, вопрос задал AlenVolker , 8 лет назад

Написать программу на языке Pascal
Определить сумму чисел вводимых с клавиатуры, причем только тех, которые кратны 5 и не кратны 2
Повторюсь, ПРОГРАММУ НА PASCAL

Ответы на вопрос

Ответил petyaGavrikov
0
var n,a,s,i:integer;
begin
write('Количество чисел = ');
readln(n);
Writeln(n,' чисел:');
s:=0;
for i:=1 to n do
 begin
 readln(a);
 if (a mod 5=0)and(a mod 2<>0) then s:=s+a;
 end;
writeln('s = ',s);
end.

Пример:
Количество чисел = 10
10 чисел:
18
40
25
43
61
45
30
54
37
15
s = 85
Ответил AlenVolker
0
Спасибо. Просто то что нужно,выручил
Новые вопросы