Написать программу на языке Pascal:
Дано натуральное трёхзначное число. Найти сумму цифр этого числа.
Ответы на вопрос
Ответил alexandrkirpichyov
1
var sum,n:integer;
begin
writeln('Введите трехзначное число');
readln(n);
sum:=(n div 100)+(n div 10 mod 10)+(n mod 10);
writeln('Сумма цифр числа = ',sum);
end.
Объяснение построчно
var sum,n:integer; // Просим компьютер выделить в памяти переменные с именем sum и n типа integer(целые числа).
begin // Начало 'тела' программы
writeln('Введите трехзначное число'); // Выводим на экран текст 'Введите трехзначное число'
readln(n); // Вводим число с клавиатуры и записываем его в переменную n
sum:=(n div 100)+(n div 10 mod 10)+(n mod 10); // Суммируем цифры в нашем числе и записываем их сумму в переменную sum.
writeln('Сумма цифр числа = ',sum); // Выводим сумму цифр
end. // Конец 'тела' программы
Новые вопросы
Геометрия,
1 год назад
Математика,
1 год назад
Русский язык,
2 года назад
Русский язык,
2 года назад