Написать программу на языке Pascal.ABC
задача1
даны катеты прмоугольного треугольника а и b. найти его гипотенузу с, периметр Р и площадь S
задача2
найти длину окружности L и площадь круга S заданного радиуса R. (L=2пR; S=пR^2; считать, что п =3,14)
Ответы на вопрос
Ответил dice2057
0
Ответ:
1)
program tr;
var a,b,c,S,P:double;
begin
write('Введите 2 катеты: ');
read(a);
read(b);
c:=Sqrt((a*a)+(b*b));
writeln('Гипотенуза -',c:6:2);
P:=a+b+c;
writeln('Периметр - ',P:6:2);
S:=(a*b)/2;
writeln('Площадь - ',S:6:2);
end.
2)
program kr;
var a,b,c,S,PI,L,R:double;
begin
PI:=3.14;
write('Введите радиус: ');
read(R);
L:=2*PI*R;
writeln('Периметр - ',L:6:2);
S:=PI*Sqr(R);
writeln('Площадь - ',S:6:2);
end.
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
История,
2 года назад
Математика,
2 года назад
Физика,
8 лет назад