Информатика, вопрос задал faraon12320 , 8 лет назад

Написать программу на языке C++
Вам даётся 3 числа. Требуется установить, возможно ли составить из них пифагоров треугольник.

Входные данные
3 целых числа, по модулю не превышающие 2 000 000 000.

Выходные данные
Если из чисел возможно составить пифагоров треугольник выведите "YES", иначе "NO".

Ответы на вопрос

Ответил petyaGavrikov
0
#include <iostream>
using namespace std;

int main() {
int a, b, c;
cout << "a, b, c: ";
cin >> a >> b >> c;
if ((a*a+b*b==c*c)||(a*a+c*c==b*b)||(b*b+c*c==a*a))
  cout << "YES";
else cout << "NO";
return 0;
}

Пример:
a, b, c: 1960509751 395427000 1999990249
YES
Ответил Аноним
0
А в какой это версии С++ под переменную типа int отводится 8 байт?
Ответил Аноним
0
Может, лучше объявить long long int?
Новые вопросы