Информатика, вопрос задал simba8729 , 2 года назад

Написать программу на языке C++: Даны катеты двух прямоугольных треугольников a1;b1 и a2;b2. У какого из двух треугольников больше периметр (гипотенуза c^2=a^2+b^2).

Приложения:

122234567898764: а что нужно вывести?
simba8729: Сам не знаю, вот такое задание дали.
122234567898764: а катеты в каком диапазоне (до 10 в 9?)
simba8729: Я сейчас скрин задания вставлю.
122234567898764: если что то непонятно спрашивай
simba8729: Спасибо большое, выручил!
122234567898764: Выручила)

Ответы на вопрос

Ответил 122234567898764
1

Ответ:

Объяснение:

#include <bits/stdc++.h>

using namespace std;

int bigger_P(int a, int b, int c, int d)

{

   if(a+b+sqrt(pow(a, 2)+pow(b, 2))>c+d+sqrt(pow(c, 2)+pow(d, 2)))return 1;

   if(a+b+sqrt(pow(a, 2)+pow(b, 2))<c+d+sqrt(pow(c, 2)+pow(d, 2)))return 0;

   return -1;

}

int main()

{

   ios_base::sync_with_stdio(0);

   cin.tie(0);

   cout.tie(0);

   int a, b, c, d;

   cin>>a>>b>>c>>d;

   if(bigger_P(a, b, c, d)==1)cout<<"First perimetr is bigger.";

   if(bigger_P(a, b, c, d)==0)cout<<"Second perimetr is bigger.";

   if(bigger_P(a, b, c, d)==-1)cout<<"They are equal.";

   return 0;

}

Новые вопросы