Написать программу на ЯП Паскаль для вычисления площади треугольника по его сторонам AB, BC, CA (формула Герона). Программу написать на 13 строк.
Ответы на вопрос
Ответил angryfukse
0
//PASCAL ABC.NET
var
s, p, ab, bc, ca: real;
begin
read(ab, bc, ca);
p := (ab + bc + ca) / 2;
s := sqrt(p * (p - ab) * (p - bc) * (p - ca));
writeln(p, #10, s);
end.
Ответил elenaklon
0
Ровно 13 строк:
program Geron;
var ab,bc,ca,p: real;
begin
writeln('Определение площади треугольника по теореме Герона');
write('Введите сторону треугольника AB: ');
readln(ab);
write('Введите сторону треугольника BC: ');
readln(bc);
write('Введите сторону треугольника CA: ');
readln(ca);
p:=(ab+bc+ca)/2;
writeln('Площадь треугольника равна ',sqrt(p*(p-ab)*(p-bc)*(p-ca)):0:3)
end.
Новые вопросы