Написать программу на СИ...... Среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.
Ответы на вопрос
Ответил petyaGavrikov
0
#include <stdio.h>
int main(void) {
double x,y,z;
int a,b,c;
printf("x = ");
scanf("%lf", &x);
x = x*10;
y = modf(x,&z);
a = (int)z%10;
x = x*10;
y = modf(x,&z);
b = (int)z%10;
x = x*10;
y = modf(x,&z);
c = (int)z%10;
if (a*b*c == 0) printf("Yes");
else printf("No");
return 0;
}
Пример:
x = 3.40249
Yes
int main(void) {
double x,y,z;
int a,b,c;
printf("x = ");
scanf("%lf", &x);
x = x*10;
y = modf(x,&z);
a = (int)z%10;
x = x*10;
y = modf(x,&z);
b = (int)z%10;
x = x*10;
y = modf(x,&z);
c = (int)z%10;
if (a*b*c == 0) printf("Yes");
else printf("No");
return 0;
}
Пример:
x = 3.40249
Yes
Ответил Milton812
0
#define _CRT_SECURE_NO_WARNINGS
#include <stdlib.h>
#include <stdio.h>
#include <locale>
int main()
{
setlocale(LC_ALL, "RUSSIAN");
float a;
int b;
bool flag=false;
char str[20];
printf("Введите число >> ");
scanf("%f", &a);
b = a;
float c = a - b;
sprintf(str, "%5.3f", c);
printf("Дробная часть: %s", str);
for (int i = 2; i < 5; i++)
{
if (str[i] == '0')
flag = true;
}
if (flag == true)
printf("nПервые три цифры дробной части содержат цифру 0");
else
printf("nПервые три цифры дробной части не содержат цифру 0");
printf("n ");
system("pause");
}
#include <stdlib.h>
#include <stdio.h>
#include <locale>
int main()
{
setlocale(LC_ALL, "RUSSIAN");
float a;
int b;
bool flag=false;
char str[20];
printf("Введите число >> ");
scanf("%f", &a);
b = a;
float c = a - b;
sprintf(str, "%5.3f", c);
printf("Дробная часть: %s", str);
for (int i = 2; i < 5; i++)
{
if (str[i] == '0')
flag = true;
}
if (flag == true)
printf("nПервые три цифры дробной части содержат цифру 0");
else
printf("nПервые три цифры дробной части не содержат цифру 0");
printf("n ");
system("pause");
}
Новые вопросы
Алгебра,
2 года назад
Математика,
2 года назад
Математика,
8 лет назад
Математика,
8 лет назад
Алгебра,
9 лет назад
Алгебра,
9 лет назад