Информатика, вопрос задал himikto , 8 лет назад

Написать программу на Си с использованием массивов

Приложения:

Ответы на вопрос

Ответил petyaGavrikov
0
При поиске номера билета в таблице выигрышей упорядоченность никак не учитывается!
#include <stdio.h> 
#include <stdlib.h>

int main() 

   int n=10;
   int a[n][2];
   int s[3] = {1000, 2000, 3000};
   int k, m;
   int sum=0;

   srand (time(NULL)); 
   for (int i=0; i<n; i++)  
   {
        a[i][0] = 1000*i+(rand() % 1000 + 1);
        a[i][1] = s[rand()%3];
        printf ("%5d %5d", a[i][0], a[i][1]);
    printf("n");
   }
    printf("k = ");
    scanf("%d",&k);
    printf("Вводите номера билетов:");
    for (int j = 1; j<k; j++) {
    scanf("%d",&m);
    for (int i=0; i<n; i++) {
    if (a[i][0] == m) sum+=a[i][1];
    }
    }
    printf("Сумма выигрыша = %5dn", sum);
    return 0;
}

Пример:
 372 2000
1258 2000
2265 1000
3583 1000
4582 1000
5471 2000
6637 3000
7151 1000
8520 1000
9631 1000
k = 3
Вводите номера билетов:
1258
3571
8520
Сумма выигрыша = 3000
Новые вопросы