Написать программу на Си (метод ньютона)
В соответствии с этим методом каждое следующее приближение к корню ищется по формуле: 
Итерационный процесс уточнения корня заканчивается при достижении условия:
< ε где ε – заданная точность.
уравнение: 3х-4ln-5=0
отрезок содержащий корень [2;4]
точность 10^(-4)
Ответы на вопрос
Ответил VolumSeparatum
0
Как-то так, прилагаю и сам сpp-файл :)
#include<stdio.h>#include<math.h>
const double EPS = 1e-4;
double f(double x){ return 3*x - 4 * log(x) - 5;}
double fp(double x){ return 3 - 4 * (1/x);}
int main(){ double prev = 2, cur; //prev - x (k-1)ое, cur - x k-тое cur = prev - f(prev)/fp(prev); while(abs(cur - prev) > EPS) { prev = cur; cur = cur - f(cur)/fp(cur); }
printf("%lfn", cur); return 0;}
#include<stdio.h>#include<math.h>
const double EPS = 1e-4;
double f(double x){ return 3*x - 4 * log(x) - 5;}
double fp(double x){ return 3 - 4 * (1/x);}
int main(){ double prev = 2, cur; //prev - x (k-1)ое, cur - x k-тое cur = prev - f(prev)/fp(prev); while(abs(cur - prev) > EPS) { prev = cur; cur = cur - f(cur)/fp(cur); }
printf("%lfn", cur); return 0;}
Приложения:
Ответил Аноним
0
у меня не работает, выдает :(Ошибка 1 error LNK2019: ссылка на неразрешенный внешний символ _main в функции ___tmainCRTStartup и Ошибка 2 fatal error LNK1120: 1 неразрешенных внешних элементов )
Ответил VolumSeparatum
0
какой компилятор?
Ответил VolumSeparatum
0
хотяя, ошибку-то линкер выдает...
Ответил VolumSeparatum
0
На чем ты запускаешь ее? Я на VS2010 работаю) там все работает, могу экзешник кинуть :D
Ответил VolumSeparatum
0
а нет, не могу :)
Новые вопросы