Информатика, вопрос задал nlo78 , 7 лет назад

Написать программу на си или хотя бы объяснить как это математически решается

Приложения:

Ответы на вопрос

Ответил settom
0

Ответ:

#include <iostream>

using namespace std;

int main()

{

   setlocale(LC_ALL, "rus");

   double x,y;

   bool InArea = false;

   cout << "Введите x = ";

   cin >> x;

   cout << "Введите y = ";

   cin >> y;

   // Проверяем попала ли точка в область между корнем из x и осью x

   if (y <= sqrt(x) && y >=0) InArea = true;

   // Проверяем попала ли точка в область между четвертью окружности и осью x

   // тут кстати в формуле ошибка, должно быть (x-4)^2+y^2=4

   if ( (x - 4) * (x - 4) + y * y <= 4) InArea = true;

   if (InArea) cout << "Точка находится в области";

   else cout << "Точка не находится в области";

}

Новые вопросы