Информатика, вопрос задал thebraveredlynx , 7 лет назад

Написать программу на С++.
Ввести массив из n чисел. Определить минимальный элемент среди отрицательных элементов и его порядковый номер.

Ответы на вопрос

Ответил restIess
0

Ответ находится во вложении.

Приложения:
Ответил vimmortal2
0

Программа:

С++:

#include <iostream>

using namespace std;

int main()

{

   setlocale(LC_ALL, "rus");

   int i, n, min, index;

   int* arr = new int[n];

   

   cout << "n = ";  cin >> n;

   min = 0;

   for(i = 1; i <= n; i++) {

       cin >> arr[i];

   }

   

   for(i = 1; i <= n; i++) {

       if (arr[i] < 0 & arr[i] < min) { min = arr[i]; index = i; }

   }

   

   cout << "Минимальный элемент: " << min << ". Его индекс: " << index;

}

Новые вопросы