Написать программу на с++
Вектор на плоскости: координаты
вектора на плоскости (x1, y1, x2, y2)
Два вектора с общим
началом ( x1, y1) на
плоскости: координаты первого вектора –
x1, y1, x2, y2; координаты второго вектора
– x1, y1, x3, y3
Определить координаты
вектора суммы двух
векторов.
СРОЧНО! СПАСИБО)
Ответы на вопрос
Ответил YuraPy
0
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
float x1, y1, x2, y2, x3, y3, v1, v2, b1, b2;
cout << "x1 y1: ";
cin >> x1 >> y1;
cout << "x2 y2: ";
cin >> x2 >> y2;
cout << "x3 y3: ";
cin >> x3 >> y3;
v1 = x1 + x2;
v2 = y1 + y2;
b1 = x1 + x3;
b2 = y1 + y3;
cout << "Sum 1: " << "(" << v1 << ";" << v2 << ")" << endl;
cout << "Sum 2: " << "(" << b1 << ";" << b2 << ")";
}
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Математика,
6 лет назад
Обществознание,
6 лет назад
Математика,
8 лет назад